mercoledì, Novembre 30, 2022
HomeMicrosoft OfficeExcel13 Funzioni essenziali di Excel per l'immissione di dati

13 Funzioni essenziali di Excel per l’immissione di dati

L’inserimento dei dati nel foglio di calcolo è il principio di base alla base dell’utilizzo di Excel. Dall’aggiunta della data e dell’ora correnti alla ricerca dei valori alla modifica delle lettere maiuscole del testo, alcune  funzioni possono aiutarti  enormemente con l’immissione dei dati.

Immettere la data e l’ora correnti: OGGI e ORA

Potresti voler vedere la data corrente con o senza l’ora ad ogni apertura del tuo foglio. La funzione OGGI fornisce la data corrente e la funzione ADESSO fornisce la data e l’ora.

La sintassi per ciascuna funzione è abbastanza semplice. Utilizzare TODAY()NOW()senza argomenti o caratteri tra parentesi.

Basta inserire la seguente formula per la funzione che desideri, premere Invio o A capo e ogni volta che apri il foglio, sarai aggiornato.

=OGGI()
=ORA()

Ottieni parti di una stringa di testo: SINISTRA, DESTRA e MID

Se stai lavorando con stringhe di testo in cui devi ottenere parte di quella stringa per la tua voce, puoi farlo con le funzioni SINISTRA, DESTRA e MID.

La sintassi di ciascuna funzione è la seguente:

  • LEFT(text, number_characters), primo argomento richiesto
  • RIGHT(text, number_characters), primo argomento richiesto
  • MID(text, start_number, number_characters), tutti gli argomenti richiesti

Con questa formula puoi ottenere i primi cinque caratteri della stringa di testo nella cella A1:

=SINISTRA(A1,5)

Funzione SINISTRA in Excel

Con la formula successiva, puoi ottenere gli ultimi cinque caratteri nella stringa di testo nella cella A1:

=DESTRA(A1,5)

Funzione DESTRA in Excel

E con questa formula, puoi ottenere i cinque caratteri che iniziano con il settimo carattere nella cella A1:

=MEDIO(LA1,7,5)

Funzione MID in Excel

Cambia la lettera maiuscola: SUPERIORE, INFERIORE e PROPRIO

Forse hai delle incongruenze nel modo in cui è stato inserito il testo nel tuo foglio. Puoi convertire le lettere in maiuscolo o minuscolo o mettere in maiuscolo la prima lettera di ogni parola con MAIUSC, LOWER e PROPER.

La sintassi per ciascuno è la stessa con l’argomento richiesto:

  • UPPER(cell_reference)
  • LOWER(cell_reference)
  • PROPER(cell_reference)

Per modificare il testo nella cella A1 in tutte le lettere maiuscole, utilizzare la formula seguente:

=SUPERIORE(A1)

Per cambiare il testo in quella stessa cella in tutte le lettere minuscole, usa invece questa formula:

=INFERIORE(A1)

Per cambiare il testo in quella cella per mettere in maiuscolo la prima lettera di ogni parola, usa questa formula:

=PROPRIO(A1)

Funzione CORRETTA in Excel

Arrotonda i tuoi numeri: ROUNDUP e ROUNDDOWN

Potresti avere un foglio di calcolo contenente numeri decimali che preferisci arrotondare per eccesso o per difetto, piuttosto che visualizzare l’intera stringa. Le funzioni ROUNDUP e ROUNDDOWN in Excel ti consentono di arrotondare facilmente i numeri.

Le sintassi sono ROUNDUP(number, number_digits)ROUNDDOWN(number, number_digits)dove sono richiesti entrambi gli argomenti per ciascuno.

Per arrotondare di due cifre il numero nella cella A1, utilizzare questa formula:

=ARROTONDA.PER.(A1,2)

Funzione ARROTONDA in Excel

Per arrotondare lo stesso numero per difetto di due cifre, dovresti usare questa formula:

=ARROTONDA.BASSO(A1,2)

Funzione ARROTONDAMENTO in Excel

Utilizzare un numero positivo per l’ number_digitsargomento per arrotondare le cifre decimali a destra e un numero negativo per arrotondare le cifre decimali a sinistra.

Rimuovi gli spazi non necessari: TRIM

Forse hai spazi extra nelle tue celle che vuoi rimuovere. La funzione TRIM elimina gli spazi.

La sintassi per la funzione è TRIM(text)dove puoi usare un riferimento di cella o inserire il testo tra virgolette.

Per rimuovere gli spazi extra nel testo nella cella A1, utilizzare il riferimento di cella come in questa formula:

=TRIM(A1)

Funzione TRIM in Excel

Per rimuovere gli spazi aggiuntivi nella frase "   Extra   Spaces   "dovresti usare la seguente formula:

=TRIM("Spazi extra")

TAGLIARE il testo in Excel

Confronta un valore e restituisci un risultato: SE

La funzione SE è uno strumento popolare per confrontare valori e restituire risultati numerici o testuali. Puoi quindi analizzare quei risultati o usarli altrove come in un’altra formula.

La sintassi è IF(test, output_if_true, output_if_false)dove sono richiesti i primi due argomenti.

Per verificare il valore nella cella A1, che è un’opzione Sì o No, e restituire un 1 per Sì e 2 per No, dovresti utilizzare questa formula:

=SE(A1="Sì",1,2)

SE un valore è uguale a funzione

Per un esempio di testo, puoi vedere se un valore (A1) è maggiore di un altro valore (B1) e quindi restituire “Over” se lo è e “Under” se non lo è.

=SE(LA1>B1,"Sopra","Sotto")

SE un valore è maggiore della funzione

Cerca valori: XLOOKUP

Quando devi cercare un valore o un testo da un’altra posizione e inserirlo nel tuo foglio, la funzione XLOOKUP è l’ideale.

La sintassi è XLOOKUP(value, lookup, return, not_found, match_code, search_code)dove i primi tre argomenti sono obbligatori e gli ultimi tre sono facoltativi.

Poiché abbiamo un tutorial completo sulla funzione XLOOKUP in Excel che approfondisce ulteriormente, qui utilizzeremo esempi di base.

Per trovare il numero di telefono di un cliente, puoi utilizzare questa formula:

=XLOOKUP(G2,LA2:LA10,C2:C10)

Per scomporre la formula, G2 è il valore da trovare, A2:A10 è dove cercare il valore e C2:C10 è dove trovare il valore da restituire.

XLOOKUP per un campo

Come altro esempio, puoi utilizzare questa formula per trovare sia il numero di telefono che l’indirizzo email di quel cliente:

=XLOOKUP(G2,LA2:LA10,B2:C10)

Qui, abbiamo semplicemente ampliato l’ returnargomento per coprire ogni colonna che include il numero di telefono e l’indirizzo e-mail (B2:C10). Quindi, la formula ha fornito entrambi i risultati.

XLOOKUP per due campi

L’immissione dei dati è sufficiente per un’attività da sola. Si spera che tu possa semplificare l’utilizzo di queste funzioni di immissione dei dati di Excel.

RELATED ARTICLES

Ultime Notizie

Ultimi Tutorial