mercoledì, Novembre 30, 2022
HomeMicrosoftCome contare le celle con il testo in Excel

Come contare le celle con il testo in Excel

Vuoi contare il numero di celle che contengono uno o un testo specifico ignorando tutte le altre celle? In tal caso, Microsoft Excel ha una funzione dedicata per aiutarti a farlo. Ti mostreremo come usarlo.

In Excel, puoi utilizzare la funzione CONTA.SE per contare le celle contenenti qualsiasi testo o le celle contenenti testo specifico. Usa il metodo di seguito che funziona per la tua situazione specifica.

Conta le celle con qualsiasi testo in Excel

Innanzitutto, apri il foglio di calcolo con Microsoft Excel. Nel foglio di calcolo, seleziona la cella in cui desideri visualizzare il risultato.

Seleziona una cella in un foglio di calcolo Excel.

Nella cella selezionata, digita la seguente COUNTIFfunzione e premi Invio. Assicurati di sostituire D2D6in questa funzione con l’intervallo in cui si trovano le celle da contare.

=CONTA.SE(D2:D6,"*")

Qui, l’argomento * (asterisco) dice alla funzione di contare solo le celle che contengono testo.

Inserisci la funzione CONTA.SE per contare tutte le celle di testo.

Puoi anche contare le celle che contengono qualsiasi cosa tranne il testo. Per fare ciò, utilizzare la seguente versione modificata della COUNTIFfunzione. In questa funzione, l’argomento specifica che devono essere contate solo le celle non di testo.

Se una cella contiene sia testo che numeri, non verrà conteggiata.

=CONTA.SE(D2:D6;"<>*")

Inserisci la funzione CONTA.SE per contare tutte le celle non di testo.

Questo è il risultato che vedrai quando usi la funzione CONTA.SE per contare il numero di celle che contengono qualsiasi testo.

Il numero di celle contenenti qualsiasi testo.

Conta le celle con testo specifico in Excel

Per fare in modo che Excel conti solo le celle che contengono testo specifico, usa un argomento con la COUNTIFfunzione.

Innanzitutto, nel foglio di calcolo, seleziona la cella in cui desideri visualizzare il risultato.

Seleziona una cella in un foglio di calcolo Excel.

Nella cella selezionata, digita la seguente COUNTIFfunzione e premi Invio. Nella funzione, sostituisci D2D6con l’ intervallo in cui si trovano le tue celle. Inoltre, sostituisci acon qualsiasi carattere o parola che la tua cella dovrebbe avere per essere conteggiata.

La funzione seguente conta tutte le celle che contengono la lettera a. Ciò significa che, nel nostro esempio, conterà entrambi MaheshDavidpoiché entrambi questi nomi contengono la lettera a.

=CONTA.SE(D2:D6;"*a*")

Inserisci la funzione CONTA.SE per contare le celle contenenti testo specifico.

Ecco il risultato:

Il numero di celle contenenti testo specifico.

Per fare in modo che la funzione conti quelle celle che contengono solo il carattere o la parola specificati, rimuovi il segno * (asterisco) prima e dopo il carattere o la parola, come segue.

=CONTA.SE(D2:D6,"a")

Inserisci la funzione CONTA.SE per contare le celle che contengono solo testo specifico.

Nel nostro esempio, il risultato del conteggio è 0perché non ci sono celle che contengono solo il carattere ain esse.

Il numero di celle contenenti solo testo specifico.

Ed è così che specifichi quali celle considerare per il calcolo nei fogli di calcolo di Microsoft Excel. Molto utile!

RELATED ARTICLES

Ultime Notizie

Ultimi Tutorial