domenica, Dicembre 4, 2022
HomeMicrosoft OfficeExcelCome contare le celle in Excel

Come contare le celle in Excel

Excel fornisce vari metodi per contare le celle, incluso l’uso della funzione Trova o di un filtro. Ma con le funzioni, puoi contare esattamente ciò di cui hai bisogno. Dalle celle piene agli spazi vuoti, dai numeri al testo, ecco come contare le celle in Excel.

Se vuoi contare il numero di celle che contengono solo numeri, puoi usare la funzione COUNT. La sintassi per la formula è: COUNT(value1, value2,...)dove value1è obbligatorio ed value2è facoltativa.

Userai value1per i tuoi riferimenti di cella, l’intervallo di celle in cui vuoi contare. Puoi utilizzare value2(e gli argomenti successivi) per aggiungere un numero particolare o un altro intervallo di celle, se lo desideri. Diamo un’occhiata a un paio di esempi.

Per contare il numero di celle nell’intervallo da A1 a D7 che contiene numeri, digitare quanto segue e premere Invio:

=CONTEGGIO(A1:D7)

COUNT formula in Excel

Riceverai quindi il risultato nella cella contenente la formula.

COUNT risultato

Per contare il numero di celle in due intervalli separati da B2 a B7 e da D2 a D7 che contengono numeri, digitare quanto segue e premere Invio:

=CONTEGGIO(B2:B7,D2:D7)

COUNT formula per gli intervalli

Ora vedrai il conteggio totale dei numeri per entrambi questi intervalli di celle.

COUNT risultato per intervalli

Conta celle vuote: la funzione COUNTBLANK

Forse quello che vuoi trovare è il numero di celle vuote che hai in un particolare intervallo. Utilizzerai una variante della funzione COUNT, COUNTBLANK. La sintassi per la formula è: COUNTBLANK(value1)dove value1contiene i riferimenti di cella ed è obbligatorio.

Per contare il numero di celle vuote nell’intervallo da A2 a C11, digitare quanto segue e premere Invio:

=CONTA.VUOTE(A2:C11)

Formula COUNTBLANK in Excel

Vedrai quindi il risultato nella cella in cui hai inserito la formula.

COUNTBLANK risultato

Conta celle non vuote: la funzione CONTA.VALORI

Forse ti piacerebbe fare l’esatto contrario di contare le celle vuote e invece contare le celle che contengono dati. In questo caso, utilizzerai la funzione CONTA.VALORI. La sintassi è COUNTA(value1, value2,...)dove value1è richiesta ed value2è facoltativa.

Proprio come la funzione COUNT sopra , value1è per i riferimenti di cella ed value2è per gli intervalli aggiuntivi che desideri includere.

Per contare il numero di celle non vuote nell’intervallo da A2 a C11, digitare quanto segue e premere Invio:

=CONTA.VALORI(A2:C11)

Formula CONTA.VALORI in Excel

Come puoi vedere, la funzione CONTA.VALORI conta le celle contenenti qualsiasi tipo di dati. Ciò include numeri, testo, errori e testo o stringhe vuote. Ad esempio, viene conteggiato l’errore nella cella C7.

CONTA risultato

Se un errore ti crea problemi, è facile nascondere i valori di errore nei fogli di lavoro .

Contare le celle con criteri specifici: la funzione CONTA.SE

Se desideri contare il numero di celle contenenti dati specifici, utilizzerai la funzione CONTA.SE. La sintassi per la formula è COUNTIF(value1, criteria)dove entrambi value1criteriasono richiesti.

Come le altre funzioni qui, value1contiene i riferimenti di cella per l’intervallo. Criteriaè l’elemento che si desidera cercare e può essere un riferimento di cella, una parola, un numero o un carattere jolly. Diamo un’occhiata a un paio di esempi di base.

Per contare il numero di celle nell’intervallo da C2 a C6 che contengono la parola “calzini”, digitare quanto segue e premere Invio:

=CONTA.SE(C2:C6;"calze")

CONTA SE formula di testo in Excel

Nota che se il tuo criterio è una parola, devi racchiuderla tra virgolette.

COUNTIF testo risultato

Per contare il numero di celle nell’intervallo da B2 a C6 che contengono il contenuto della cella B2, digitare quanto segue e premere Invio:

=CONTA.SE(B2:C6,B2)

CONTA.SE formula di riferimento di cella in Excel

In questo caso, non inseriresti il ​​riferimento di cella B2 tra virgolette.

CONTA.SE riferimento cella risultato

 

RELATED ARTICLES

Ultime Notizie

Ultimi Tutorial