mercoledì, Novembre 30, 2022
HomeMicrosoftExcel: come trovare il giorno della settimana da una data

Excel: come trovare il giorno della settimana da una data

Hai una data nel tuo foglio di calcolo che vuoi trasformare nel giorno della settimana? In tal caso, Microsoft Excel ha più caratteristiche e funzioni per aiutarti a farlo. Ti mostreremo come usarli.

Modi per trovare il giorno della settimana da una data in Excel

Per trovare il giorno della settimana da una data, hai fondamentalmente tre modi. Il primo metodo consiste nel trasformare la data nel giorno della settimana in forma numerica. In questo metodo, la domenica viene visualizzata come numero 1, lunedì come numero 2 e così via. Questo viene calcolato con la funzione WEEKDAY di Excel.

Il secondo metodo visualizza il nome effettivo del giorno della settimana, ad esempio domenica, lunedì e così via. Questo metodo utilizza la TEXTfunzione di Excel che converte la data nel formato del giorno .

Il terzo metodo riformatta le date effettive e le visualizza come i nomi del giorno della settimana, come domenica, lunedì e così via. Se utilizzi questo metodo, non hai bisogno di una colonna separata per visualizzare i giorni, poiché la data esistente viene sovrascritta.

Trova il giorno della settimana come numero

Per trovare il giorno della settimana come numero, utilizzare la WEEKDAYfunzione di Excel come segue. Il conteggio inizia da domenica, dove è numerato 1. Tuttavia, puoi far contare la funzione da qualsiasi giorno scelto (come lunedì), come spiegheremo di seguito.

Per iniziare, per prima cosa apri il tuo foglio di calcolo con Microsoft Excel. Nel foglio di calcolo, assicurati di avere almeno una data. Quindi seleziona la cella in cui desideri visualizzare il giorno della settimana.

Seleziona una cella in un foglio di calcolo Excel.

Nella cella selezionata, digita la seguente WEEKDAYfunzione e premi Invio. In questa funzione, sostituisci B2con la cella in cui hai la tua data.

=GIORNO DELLA SETTIMANA(B2)

Immettere la funzione WEEKDAY.

Se desideri utilizzare la data direttamente nella funzione, digita la seguente WEEKDAYfunzione con la tua data e premi Invio. Tieni le virgolette doppie intorno alla tua data.

=GIORNOSETTIMANA("24/5/2021")

Immettere la funzione WEEKDAY con valori diretti.

E nella cella selezionata, vedrai il giorno della settimana per la tua data come un numero.

Il risultato della funzione WEEKDAY.

Per fare in modo che la funzione conti i giorni in modo che lunedì sia il numero 1, modificare la funzione come segue. Il numero 2nell’argomento della funzione gli dice di iniziare a contare da lunedì.

=GIORNOSETTIMANA(B2,2)

Digitare la funzione WEEKDAY personalizzata.

Ecco come appare ora il tuo risultato:

Il risultato della funzione WEEKDAY personalizzata.

Per copiare la funzione in altre celle, trascina verso il basso dall’angolo in basso a destra della cella in cui hai digitato la funzione.

Copia la funzione WEEKDAY.

Trova il giorno della settimana come nome

Per visualizzare il giorno della settimana di una data come nome del giorno, ad esempio lunedì, utilizzare la TEXTfunzione di Excel . In questa funzione, dici a Excel di formattare la tua data nel formato del giorno. Puoi scegliere il nome del giorno abbreviato (come Mon) o il nome completo del giorno (come Lunedi).

Inizia aprendo il foglio di calcolo con Microsoft Excel. Quindi seleziona la cella in cui desideri visualizzare il giorno della settimana.

Fare clic su una cella in un foglio di calcolo di Excel.

Nella cella selezionata, digita la seguente TEXTfunzione e premi Invio. In questa funzione, sostituisci B2con la cella in cui si trova la tua data.

=TESTO(B2,"gggg")

Inserisci la funzione TESTO.

La cella selezionata visualizzerà il giorno della settimana. Se preferisci un nome del giorno abbreviato, come “Mon” per lunedì, rimuovine uno ddall’argomento della funzione come segue:

=TESTO(B2,"gg")

Digitare la funzione TESTO personalizzata.

E ora hai il nome del giorno abbreviato nella cella selezionata.

Il risultato della funzione TEXT personalizzata.

Converti le date in giorni della settimana

Per convertire le date in giorni di settimane senza utilizzare una colonna separata , utilizza il formato numerico personalizzato di Excel. Visualizza il giorno della settimana con il suo nome completo o abbreviato.

Per fare ciò, per prima cosa apri il tuo foglio di calcolo con Microsoft Excel. Quindi seleziona le celle contenenti le date.

Seleziona le celle della data.

Nella barra multifunzione di Excel in alto , fai clic sulla scheda “Home”.

Fare clic sulla scheda "Home" in Excel.

Nella scheda “Home”, dalla sezione “Numero”, seleziona “Formato numero” (un’icona a forma di freccia).

Seleziona "Formato numero" nella scheda "Home".

Si aprirà una finestra “Formatta celle”. In questa finestra, dall’elenco “Categoria” a sinistra, seleziona “Personalizzato”.

Seleziona "Personalizzata" nella finestra "Formato celle".

A destra, fai clic sulla casella “Tipo” e inserisci “dddd” (senza virgolette) per i nomi di giorni interi (come lunedì) o “ddd” per i nomi di giorni abbreviati (come lunedì). Quindi, in basso, fai clic su “OK”.

Specificare il formato della data.

Excel trasformerà le date selezionate in giorni della settimana.

Le date sono diventate giorni della settimana.

Ed è così che sai che giorno era in una data specifica in Microsoft Excel. Molto utile!

RELATED ARTICLES

Ultime Notizie

Ultimi Tutorial